Portfolio Backtester vs. Strategy Performance Report

Questions about MultiCharts and user contributed studies.
XIKON
Posts: 21
Joined: 15 Dec 2010
Has thanked: 3 times
Been thanked: 3 times

Portfolio Backtester vs. Strategy Performance Report

Postby XIKON » 13 Feb 2012

Dear All,

The report I am getting under strategy performance report has got me in a trade on a certain date. However when the same strategy is run under portfolio backtester it doesn't get me in the trade. Not sure why I am getting two different results. I have looked at the settings and nothing seems out of the normal.

Would you be able to help and point out what the problem may be? The strategy is a very simple one to buy 1 share on a certain date and sell on a certain date. I am using the following:

>>>>>

Code: Select all

condition1 = Date = ELDate (12, 30, 1999);
condition2 = Date = ELDate (12, 30, 2011) ;

if condition1 then Buy ( "ENTRY" ) at NEXT bar at market;
if condition2 then SELL ("EXIT")at THIS BAR AT CLOSE;


>>>>>

I would greatly appreciate any help.

Many thanks and regards,

XIKON

User avatar
Henry MultiСharts
Posts: 8521
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2741 times

Re: Portfolio Backtester vs. Strategy Performance Report

Postby Henry MultiСharts » 14 Feb 2012

Hello Xikon,

Please make sure that you have one instrument both in MC and Portfolio Backtester.
The Data Range should be specified as From_ To_ and not Days/Bars Back.
The resolution should be the same both in MC and Portfolio Backtester.

The settings in the Strategy Properties window should have no differences both in MC and Portfolio Backtester.
In the Money Management Settings section Max % of Capital at Risk per Position should be 100%.
In the Money Management Settings section Initial Portfolio Capital should be maximum, e.g. $1 000 000.

Your script generates the same results in MultiCharts and Porfolio Backtester if the settings are the same.

XIKON
Posts: 21
Joined: 15 Dec 2010
Has thanked: 3 times
Been thanked: 3 times

Re: Portfolio Backtester vs. Strategy Performance Report

Postby XIKON » 15 Feb 2012

Dear Henry,

Many thanks for the help. It is working now. All settings were identical except the data range. I had forgotten to include a range rather than bars back.

Many thanks again.

Best regards,

XIKON


Return to “MultiCharts”