+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-1812

Portfolio report "Failed to save file"

action_vote_minus_faded.png
2
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Saving portfolio report with OpenOffice ends with red message "Failed to save file". I have exported several hundred and seen this on many of them.

This forum topic appears to be describing the same thing and implies there may be dll updates that can fix the problem: http://www.multicharts.com/discussion/viewtopic.php?f=1&t=47464

However I am running latest version of Multicharts x64 v9.0.10360 and still get the problem. I tried updating everything else..latest version of Openoffice 4.1.1. Windows 7 with all updates applied.

Steps to reproduce this issue

Export portfolio report to ods. You may get "Failed to save file" after "Writing overview by symbols sheet...". See attachments to reproduce.

Comments (2)
#0
user-offline.png  FastLane (Enalmada)
Dec 14, 2014 - 18:45

I am not sure if it is relevant or not, but because it stops ofter "Writing overview by symbols sheet.." it made me think perhaps there was something wrong with Ratio By Symbols which comes next. I see a few symbols with huge numbers in there: Sharpe Ratio: (146202956.32) Sortino Ratio: (206762203.73). Perhaps there is something crashing when trying to export a number with an unexpectedly big size for this field?

#0
user-offline.png  FastLane (Enalmada)
Jan 20, 2015 - 03:11

I have added a testcase (FailedToSave2) with only 2 assets and a few trades.  So hopefully this makes it very easy to reproduce and debug. OpenOffice is only 32bit so perhaps a bad number is causing the crash...just guessing.

History
Issue basics
  • Type of issue
    Bug report
  • Category
    Usability
  • Targeted for
    MultiCharts 9.1 (RELEASED)
  • Status
    Released
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (2)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
  • Severity
    Normal
Attachments (3)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates