+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report MC-2043

From TS to MC Futures Symbol - Missing Days of Data Consistently

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Released" and resolution "Not determined".
Description

MC does not import about a days worth of a futures symbols data.
The missing data is about 1-2 days before the contract ends.

Steps to reproduce this issue

When MC is connected to TS for data.
In MC command line TS:NGF16
After data loads almost all bars from 12/28/2015 are not downloaded from TS.
Screencast.

https://www.youtube.com/watch?v=O5PwYsE7Tug

The only way to fix this is to make a chart in MC of 12/28/2015-12/29/2015 and hit refresh.

Comments (3)
#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 04, 2016 - 10:41

Hi,
Please try to perform the same actions in TS. What will happen in TS?

#0
user-offline.png  JoeTrader (Guest)
May 04, 2016 - 15:31

Hi,
When I pull up the chart in TS all the data is complete, nothing is missing. That's how I found out there was missing data coming to MC as I cross referenced.

#1
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Apr 10, 2017 - 10:27
Please reload the problem charts in TS first. Then reload the chart in MC by pressing CTRL+R on the chart. If the data is backfilling slow or not backfilling at all then check that TS download scheduler (TS->View tab->Launch Download Scheduler) has not queued up MC data requests. If it has then make a right click on the request->Schedule ASAP.

MC is requesting data from TS cache. And in case there is an issue with TS cache, then data in MC might be corrupted. If everything is ok with TS data and you still have issues with MC chart even after reload, then you can try and remove TS cache files.

  1. Close both MC (close MultiCharts -> make sure that no processes with MultiCharts description ( http://www.multicharts.com/trading-software/index.php/MultiCharts_Processes ) remained in Task Manager, Processes or Details tab) and TS.
  2. Rename or delete TS Cache folders, located here by default: C:\Program Files (x86)\TradeStation 9.1\Program. There are 2 folders: Cache and TSCache, need to rename/remove both.
  3. Then run MC and reload the problem chart by pressing CTRL+R on the chart.


History
Issue basics
  • Type of issue
    Bug report
  • Category
    Stability
  • Targeted for
    Not determined
  • Status
    Released
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (2)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
  • Severity
    Normal
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates