+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2237

Something wrong with Multicharts-LMAX implementation

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

I use Multicharts64 Version 10.0 release (Build 14322) for my trading.

There is somthing wrong with LMAX-Multicharts-integration/implementation.

It occured several time when closing a position in Multicharts that the position was still shown open in MC but appeared to be closed in the LMAX web application.
So I hit again "close" in MC , but following this a position in the other direction was opened. Means e.g. my originally long position was effectivly switched to a short position.
That made me lose money several times.
I do not know if the problem is on the side of Multicharts or LMAX. But the error only occurs in combination with LMAX and not with other brokers. like AMP or OANDA.
LMAX thinks From the checks they have done so far that "...it seems like there may be some kind of delay with the Multicharts platform in confirming the action to close ...".

I opend in the last few days some dozen times positions and closed them. almost always it worked as expected but sometimes not. I do not see the pattern. Only thing which came to my mind is if perhaps in the moment I want to close the position and the internet connection is down for a very short period , MC has problems to pick up the actual position from LMAX....

Steps to reproduce this issue

use chart trading to open position.
close position with "close"-button
Result: in LMAX web the position is 0, but in MC position is still open in full.
again push close-botton in MC
Result: reversed position is shown in MC and LMAX web.

Comments (1)
#1
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 17, 2017 - 09:25
We have tried to reproduce the issue on our end, but it was not reproduced.

To proceed with the investigation, we would ask you to do the following:

  1. Close MultiCharts -> make sure that no processes with MultiCharts description ( http://www.multicharts.com/trading-software/index.php/MultiCharts_Processes ) remained in Task Manager, Processes or Details tab.
  2. Open the following path for MC 64-bit: C:\Users\USERNAME\AppData\Local\TS Support\MultiCharts64 and remove this folder 10.0.14322.400.
  3. Run MultiCharts with only 1 workspace and 1 chart from LMAX and reproduce the issue there.
  4. Once the issue is reproduced, please collect the Log files using Feedback application and send it to us: https://www.multicharts.com/trading-software/index.php/MultiCharts_Logs#How_to_Send_Log_Files_Using_Feedback_Application
History
Issue basics
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates