+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2275

Only 1 in 14 stocks display due to CAD/USD clash

action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description
I described the issue in this forum thread which has the same title.

https://www.multicharts.com/discussion/viewtopic.php?t=50847
Steps to reproduce this issue

You would need an Interactive Brokers account in Canadian Dollars and be subscribed to the interactive brokers data feed for the TSE (Toronto Stock Exchange). If this is not possible maybe it is best to log into my machine and I can show the details. You would then need to enter one of the problem symbols in the quote manager. You would get no charts most likely and you would see the messages described in the forum thread.

Comments (8)
#1
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 22, 2017 - 06:44

I finally discovered you have an symbol upload feature in the quote manager. I stepped through it and it does not ask for currency whereas at least the single stock symbol entry feature does have a currency differentiation (it just does not work). So maybe it makes sense to fix the import function at the same time. However if that is going to delay the main fix I would prefer to enter the symbols manually over a weekend without the import function available.

Thanks,
John

#2
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 23, 2017 - 08:25

I forgot to mention that I am running MC 32 bit version 10.0 build 14415. However I am considering switching over to either 64 bit or even MC.net (maybe). If course I realize you have to make sure they all work so future customers do not get turned off before they buy any version of MC (regardless of country, exchange,currency) but since I was the one who reported it you probably have a bit of time before anyone else gets stung.

Anyway, thanks for reviewing it. Your project management system is great!

#3
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 23, 2017 - 17:35

I just downloaded your free trial of MC.net to see if it could load all the chart data properly. It has the same problem but there is a randomness factor such that MC.net has the same general problem on different stocks. Here are two symbols I tried.

ABX (MC fails) (MC.NET works but I have to have the daily and weekly bar data from the TSE rather than smart).

AC (MC works and all are on Smart) (MC.NET gets the minute bar data from SMART but nothing comes through on daily)

#4
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 23, 2017 - 20:41

This may help. I am using IB's TWS Mosaic. I use bigcharts every night to scan through 85 stocks that are active on the TSE and I come up with a short list of 30 or so stocks to pull up over ad over all day on the Mosaic. I bump the next review to the time I think I might need to check into them by using MS-Access which notifies me. So I know the exchange well. Every single one uses SMART and every single one works. I noticed that the data from the TSE exchange on MC is a bit different than the data from the SMART exchange. I believe MC should be using only smart because that is what Mosaic SEEMS to be using. So what Mosaic does every time is it brings up either the TSE/SMART stock or other stocks that have the same symbol and I select the one that says TSE/Smart (both are showing). So MC needs a way to know what I am going to be selecting on the Mosaic system (some sort of code or something that is 100% unique to every stock in the world). I looked up the CUSIP number on one stock thinking it must be unique and I entered that for a symbol but that did not help.

#5
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 24, 2017 - 06:31

In MC.net I had one symbol working then I deleted the data and symbol in the quote manager because I was going to try the import function (I was afraid it might muck up the import). So after I did that delete and found the import did not work I put that symbol back in. It no longer got the data. So I tried removing all the data files and doing a repair. I think the symbol was able to create the chart except I had to change the daily bars to TSE rather than SMART. I think the symbol was ABX.

If you need a list of my stock symbols I still have the import list (currently 85 symbols and slowly growing as any new ones appear in the most active list for the TSE).

I am going to go through all the symbols that are on Mosaic which have no duplicate symbol letters on a US exchange to see how many I can get to work using SMART only for minute bars and daily bars. I will update my MS-Database to know which are all smart and which are SMART and TSE. However I think I want to stick to smart since as I said above one symbol got data from SMART and TSE but the data was different. The SMART data matched Mosaic.

#6
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Jul 24, 2017 - 13:02
We have tested it on our end, but it was not reproduced.

Please come to the Live Chat Mon-Fri from 7 AM to 1 PM EST so that our developers could investigate the issue.
#7
user-offline.png  bowlesj3 (bowlesj3bt)
Jul 24, 2017 - 15:45

Its Monday and past 1 pm. I will come on to live chat with the remote ready tomorrow during market hours just after 9:30 since one or two symbols showed data but could not get real time data (most which had problems get no data at all).

#8
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Jul 25, 2017 - 11:21
1. "Generate a new tick if total volume changes" should be enabled, as currently there are issues with real-time data sent by IB when this option is disabled.

2. The instruments in the symbol list were imported incorrectly. For IB it is needed to specify the currency on the first place in the instrument description, as well as select SMART Exchange in most cases.
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    MultiCharts 10.0 (RELEASED)
  • Status
    Not a bug
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates