+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2293

OK button of "Universal DDE" windows does not close the window.

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Quote Manager: Tools -> Data Sources... -> Settings -> OK does not close the windows.
I attached my screen recording.

Version:

QuoteManager : 11.0.14589.202
Version: MultiCharts .NET64 Version 11.0 Beta 2 (Build 14589)
OS: Windows Server 2012 R2 English x64

Steps to reproduce this issue
  1. open the "Universal DDE" window
  2. click ok

the window does not close.

Comments (9)
#1
user-offline.png  Khitan (chi jeongki)
Jul 29, 2017 - 02:00
A file was uploaded. ok_button.wmvicon_open_new.png
#2
user-offline.png  Khitan (chi jeongki)
Aug 10, 2017 - 13:24

It still has a problem.

Clicking OK button pops up a dialog window "Error in Trade: Price field"

Actually, there's no error, since I opened DDE which I made before and tested working fine.
The dialog message is something wrong message.

#3
user-offline.png  Khitan (chi jeongki)
Aug 10, 2017 - 13:33
A file was uploaded. ok_button2.wmvicon_open_new.png
#4
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Aug 10, 2017 - 13:41
No, your settings were incorrect and the issues was that the error did not appear.

In Excel it is necessary to set coordinates to R1C1 format.

Then it should be set as follows: =EXCEL|'book1.xlsx'!*C1 =EXCEL|'book1.xlsx'!*C2 =EXCEL|'book1.xlsx'!*C3 etc.

C - the number of column (COLUMN) in Excel-file. In MC the instruments with the names: R1, R2, R3, where R - number of row (ROW) in the Excel file.
#5
user-offline.png  Khitan (chi jeongki)
Aug 10, 2017 - 21:51

Even if my setting were incorrect, it is still working in current build, can receive trade, ask, bid data from excel.
I guess the change in this build about DDE.

The OK button just did not worked without message in last build.
Now it shows message. What's the cause of the message?
It is looking for wild character * in the item name.
Because my setting has no * in item name, it pops up the error message now.

But, Test button worked fine, in this build also.
Test button handles like this.
If there is no * in item name, then there is no need to replace the * with symbol name.
Let's assume it is completed item name and go on.
If there is * in item name, then it prompts for symbol name, which is needed to replace wild character * in item name.
(This limits symbol name to be something like R1, R2 ... or C1, C2 .... when DDE server is excel.)

So, I changed item name from completed name to partial name with * like this.
In the order, Trade Price, Trade Volume, Bid Price, Bid Size, Ask Price, Ask Size.

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*C2

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet2'!*C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet2'!*C2

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet3'!*C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet3'!*C2

And Symbol Name to R1, since it is going to replace *.
New finding is, it works, no error message on OK button click, closed the window.
But, only Trade data is received by Quote Manager, No Ask or Bid data.
Also strange enough, Test button click, giving R1 for symbol, shows that all Trade, Ask, Bid are working.

My additional hope is that OK button also follow Test button behavior.
If there's no * in item name, then regard it as completed name and do not try to inspect *.
This is permitting one DDE Data Source be dedicated to one Symbol without using wild character *.

I attached 2 screen recording.

ok_button3.wmv:
changed item name to include *
showing that only trade data receives, even if test receive trade, ask, bid

ok_button4.wmv:
symbol and dde data source made before current version.
showing that it still works, even if item name is incorrect(?), and can receive trade, ask, bid.

#6
user-offline.png  Khitan (chi jeongki)
Aug 10, 2017 - 22:29
A file was uploaded. ok_button3.wmvicon_open_new.png
#7
user-offline.png  Khitan (chi jeongki)
Aug 10, 2017 - 22:30
A file was uploaded. ok_button4.wmvicon_open_new.png
#8
user-offline.png  Khitan (chi jeongki)
Aug 11, 2017 - 00:42

I am getting more and more disappointed, as testing goes on.

I guessed the reason why ask and bid are not received.

First try, MC.NET may not expected excel sheet can be different.
So, I moved ask and bid to the sheet trading is in.
To use symbol R1, I moved bid and ask to R1C3, R1C4, bid R1C5, R1C6.
The result was same no ask and bid data were received.

Second try, MC.NET may have set trigger point only to Trade Price Column (in standard mode, I feel no need for advanced mode since it can double the ticks and volume).
I moved bid to R2C1(price), R2C2(size), ask to R3C1, R3C2.
As a result, I have to rename symbol to R, and item name to

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*1C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*1C2

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*2C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*2C2

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*3C1

=EXCEL|'[DDE_Symbol_1.xlsx]Sheet1'!*3C2

I think this guess was correct, every update on the price column makes change(update) notification and Quote Manager reads as many times as the update notification.

But it reads Trade,

even if ask is updated, it reads trade,

even if bid is updated, it reads trade.

So, there are 3 same entries in Trade, but there's no entry in Ask and Bid viewed from Quote Manager--> Edit Data

Even in this case, the Test button shows Trade, Ask, Bid are all updated.
But in Edit Data, there's no Ask and Bid, only Trade.

#9
user-offline.png  Khitan (chi jeongki)
Aug 11, 2017 - 12:03

Since OK button works as expected(it closes the window), Let's close this case and continue at https://www.multicharts.com/pm/public/multicharts/issues/MC-2302
on the ask bid problem of the newly released version 11 Mc.net.

History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    MultiCharts 11.0 (RELEASED)
  • Status
    Released
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (4)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates