+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2344

Invalid request to OandA causes an exception

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Hi guys

An exception is returned at times by OandA due to an invalid request sent to their server from MultiCharts. The following error is logged in MultiCharts Portfolio Trader:

"10/9/2017 3:30:08 PM" "Warning" "OANDA" "" "-" "MakeRequest (POST) WebException: ; Message= "Insufficient authorization to perform request."; requestString= "https://api-fxpractice.oanda.com/v3/accounts/101-001-6358291-002/orders""

The problem is that the request passed is trying to access a version 3 of the REST API, OandA currently only supports version 1 and 2.

Thank you in advance for your assistance.

Kind regards
Ettienne Hugo

Steps to reproduce this issue
Nothing entered.
Comments (2)
#1
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Oct 17, 2017 - 14:08
Hello Ettienne,

v3 is v20 OANDA connection. Please make sure you have selected the proper Trading Interface that corresponds with your account (v1 or v20) in the data feed settings: https://www.multicharts.com/trading-software/index.php/OANDA Also make sure the proper account type is selected in Oanda broker profile: https://www.multicharts.com/trading-software/index.php/OANDA_Broker_Profile If you still have the issue after the platform is properly configured - please send us the logs for analysis and specify the time when the error occurred: go to Help tab->Feedback (or Windows Start menu->All programs->MultiCharts64->Feedback). Select two options: - Attach log files to help us understand what happened - Upload collected data to Help Desk. Uncheck the other options as we do not need them right now.
#2
user-offline.png  Ettienne (et1hugo)
icon_reply.pngOct 19, 08:44, in reply to comment #1
Hi Alex

Thank you for the feedback. I looked through the OandA API documentation and did find the sections where they use a v3 to access the REST-V20 services.

Kind regards Ettienne Hugo
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    Not determined
  • Status
    Under Review
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates