+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2384

Portfolio Performance Report - incorrect trade date when export to OpenOffice format in List of Trades list

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Hi Multicharts Support Team,

when I open Portfolio Performance Report (in Portfolio Trader) at the end of my trading day (22:15 CET) and export all to OpenOffice format then all data in Date/Time column in List of Trades is OK, but when I export the same report next day morning (for ex. 9:00 CET but before a new trading session which starts for me at 15:30 CET) and export all to OpenOffice format then in Date/Time column of List of Trades is date of actual day and not the day before when all trades executes. So when I compare the same reports but one generated the day before (the day of trading) and next day, the date/time trades are not the same and difference is 1 day.

Note:
When I open Portfolio Performance report (from Portfolio Trader) the day before and next day, data in the report is the same, difference is in exported files only.

Steps to reproduce this issue
  1. Generate some trades in Portfolio Trader
  2. When trades are closed open Portfolio Performance Report (do not stop Portfolio Trades)
  3. Export all to OpenOffce format
  4. Next day, but before new trading session (no new trades was generated) open Portfolio Performance Report
  5. Export all to OpenOffice format
  6. Compare generated files in List of Trades, column Date/Time and you will see 1 day difference
Comments (1)
#1
user-offline.png  MultiCharts Support (MultiCharts)
Feb 08, 2018 - 22:13
Hello Andrej,

We were unable to replicate this behavior on our end. Please email us examples of the reports you are having issue with.
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    Not determined
  • Status
    Need Details
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates