+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2461

Time and Price tracking does not work when I send to back an indicator

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Sending back (in the visual order) some indicators makes the feature "Track Time and Price" to stop working.

Steps to reproduce this issue
  1. New workspace
  2. Add two charts identical (same instrument, same resolution etc...)
  3. Create this indicator that I called "Test_Background_EMA":

    inputs: PosColor(green), NegColor(red);
    variables: var1_upvalue(999999),
    var2_dnvalue(-999999),
    var3_color(0);

    if c >= averagefc(c, 21) then begin
    var3_color = PosColor;
    end else
    var3_color = NegColor;

    Plot1 (var1_upvalue, "top", var3_color);
    Plot2 (var2_dnvalue, "bot", var3_color);

  4. Insert this indicator into one of the two charts (just one of the two), change the plottypes to "Bar High"
    and "Bar Low" and change the thickness to level 5 or higher.
    Change the indicator to be shown in Subgraph 1 and "User defined" in scaling, 100, -100 as values.
    Right click the indicator in the chart and change "Visual Order" to "Send to Back".
    Insert this indicator into your chart, change the PlotTypes to "Bar High" and "Bar Low" and change the thickness to level 5 or higher.

  5. Right click the indicator in the chart and change "Visual Order" to "Send to Back". (it's here that the "track time and price" feature will stop to work)
Comments (4)
#1
user-offline.png  daniele.maddaluno (daniele.maddaluno)
Jun 12, 2018 - 23:15

I don't know if this could help but I noticed that adding another indicator, after the steps described in the issue, for example a "Mov Avg 1 Line", putting it to back and invisible, makes the "Tracking Time and Price" feature to start working again.

#2
user-offline.png  daniele.maddaluno (daniele.maddaluno)
Jun 12, 2018 - 23:19
A file was uploaded. Test_Background_EMA.plaicon_open_new.png
#3
user-offline.png  daniele.maddaluno (daniele.maddaluno)
Jun 12, 2018 - 23:19
A file was uploaded. Test_Background_EMA.wspicon_open_new.png
#4
user-offline.png  MultiCharts Support (MultiCharts)
Jun 22, 2018 - 04:55
Hello Daniele,

We were unable to replicate this behavior on our end based on your description. Please attach a short video demonstrating it, or come to the live chat to demonstrate it remotely. If you are able to attach a video - please also specify the build number of MultiCharts you are running (Help tab-> About MultiCharts).
Changes:
  •   icon_status.pngStatus changed: Under Review => Need Details
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    Not determined
  • Status
    Need Details
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
Attachments (2)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates