Missing Bars and MC not correcting invalid charts

Questions about MultiCharts and user contributed studies.
PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Missing Bars and MC not correcting invalid charts

Postby PK1 » 01 Apr 2015

Hello,

I've been a few times with this problem in the Support-Chat.
I'm using IB with MC64.

The problem are missing candles / missing data happening when an IB-Datafarm is losing connection or like today QM stopped signalling the data-import and all charts stay empty even minutes after start of MC. The latter thing is new to me but similar problem and not solvable by reloading (at least I was trying a few hours trying to reload over and over).

I'm not putting any automatic system on the charts as they would not do due to the problem of missing bars in case of problems with data IB-Connection while reloading recent data (sometimes 1 day, sometimes more) ... The systems look to the bars on the left side so using an automatic system after the bug while importing data from IB happened again is not good at all. But thats's what MC is intended to handle, automatic trading systems. Very often it took me hours to reload recent days of data which could resolve the missing bars being filled. As MC is not only reloading the selected amount of days, sometimes way more like specific days from months or almost a year ago, this can be real trouble when one is dependent on MC during market hours. If this additional reloading is a bug or if there is a good reason I don't know. Even with continuous contracts basically one would think reloading 2 days will be applied to the 2 days and maybe little more but not so much more as I can see so often. Happened also in the last support chat.

Today I had gaps on a few underlyings and an extrem long candle on CL (like 2$ Candle) and reloading the data this time could not resolve the wrong charts. There is a difference while reloading in case of Tickdata / Changes / Contracts) or Minute Data. In my case I had N-Changes and Tick-Data and N-Contract-Charts which stayed invalid even after reload.

I've been explaining this problem over and over and I could show that MC is signalling me about the Disconnection from IB-Datafarm but still MC is signalling all data were correctly loaded ... which was not the case!

According to information from support missing gaps will not be filled by design, only the data after the last fill. Its by design, that's ok and shouldn't generate any problem. The problem rather is that MC is getting information in case the data connection is making trouble but MC is not handing this and thats a problem with a huge impact.

The other import thing from today paired with the invalid 2$ candle on CL and not possible to correct it via reload thats just another view on the import and not correct at all. The data is still invalid (on Charts with N-Contract-Data and Tick-Data. Charts with Minute-Data were correct after reload). Should I really edit data (what I never do) and delete the last days?

Back to the actual problem which happened so many times: I told that MC is stating in case of disconnection from a IB-Data Farm with its small red message boxes appearing in MC. As far as I could recognize the data loaded until this disconnection is fetched into MC but after that a few candles were not fetched making the chart and indicators not usable for serios things. At this point MC should handle this information not just as a message to the user instead also to get handled in the import-process. This is obviously not the case. Only the developers know why the candles are not in the data but MC is thinking the import was complete. As a developer I know this can get real tricky in bigger software architectures to handle.

I've described the problem so many times over and over, also via Screenshare on the chat and I'm short before just throwin away my license after 5 years because it costs me to much time and money and still knowing about the problem with the wrong chart data. If I would know that the import logic and possible import probs are different for other dataprovider I would change from IB but this nobody can tell.

PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Re: Missing Bars and MC not correcting invalid charts

Postby PK1 » 01 Apr 2015

yes, happens often, on weekends sometimes longtime no connection possible, but thats ok and also after session end that before futures start over IB is doing something with their datafarms, so they get disconnected for a short while. That's ok too and there is no new data during that time. Missing gaps will not get filled (by design ... at least support gave this info from dev-team) Thats ok too, because checking the whole way back if there is a gap somewhere is nearly impossible to do.

But running into the problem with inconsistent data when the dataconnection is not working, especially when MC is knowing and communicating this, that can be focussed in order to avoid inconsistent chart data.

User avatar
Henry MultiСharts
Posts: 9165
Joined: 25 Aug 2011
Has thanked: 1264 times
Been thanked: 2944 times

Re: Missing Bars and MC not correcting invalid charts

Postby Henry MultiСharts » 02 Apr 2015

Hello PK1,

Please follow Christina's suggestions and if the issue reappears - please send her the information required for further analysis.

PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Re: Missing Bars and MC not correcting invalid charts

Postby PK1 » 02 Apr 2015

@Henry Yes, thx!


Return to “MultiCharts”