save autotrading status  [SOLVED]

Questions about MultiCharts and user contributed studies.
User avatar
rrams
Posts: 56
Joined: 10 Feb 2011
Location: Arizona
Has thanked: 4 times
Been thanked: 27 times
Contact:

save autotrading status

Postby rrams » 29 May 2018

I am trying to get my charts to remember the Automate Order Execution enabled status so when I restart Multicharts it opens in Synchronous Automatic Trading mode.

On some intraday charts it correctly remembers the setting and asks on startup "Do you want to enable Auto-Trading for next strategies:". After clicking yes the SA button on the chart is green.

On daily charts at startup it also asks if I want to enable Auto-Trading and I click Yes; but SA is disabled when the workspace appears.

The Wiki states: Note: If the workspace (or MultiCharts) was closed while auto trading mode was enabled on one or several charts, a dialogue asking you if you want to enable auto trading on these charts on restart. Click Yes to enable auto trading or No to open charts with auto trading disabled.

Has this been changed? How do I get this dialog to appear so I can always start the workspace in SA enabled mode?

Thank you for listening.

MultiCharts64 Version 11.0 Release (Build 16148)

User avatar
Anna MultiCharts
Posts: 461
Joined: 14 Jul 2017
Has thanked: 31 times
Been thanked: 113 times

Re: save autotrading status

Postby Anna MultiCharts » 31 May 2018

Hello, rrams!

This hasn’t changed.
I’m a bit confused by your description. You say that “On daily charts at startup it also asks if I want to enable Auto-Trading and I click Yes; but SA is disabled when the workspace appears” and “How do I get this dialog to appear so I can always start the workspace in SA enabled mode?” – so is it that the dialog doesn’t appear each time when you open workspaces if they were closed with AT enabled? Or it is shown but AT doesn’t start each time when you click Yes?
In any case if can reproduce this please come to our Live Chat that is accessible from our web site http://www.multicharts.com/ (at the top of the page) to demonstrate this issue remotely. We'll be expecting you Mon-Fri from 6:30 AM to 12:00 PM EST (11:30 AM to 5:00 PM GMT).

User avatar
rrams
Posts: 56
Joined: 10 Feb 2011
Location: Arizona
Has thanked: 4 times
Been thanked: 27 times
Contact:

Re: save autotrading status

Postby rrams » 31 May 2018

I meant to say that the AT dialog box does display, but doesn't start in AT mode. I'm sorry for that confusion. This is actually easy for you to duplicate now that I figured out the cause.

I am using a secondary data symbol with 300 daily bars, but trading off the primary symbol with only 10 bars of data. (If you are familiar with IB backfill time, you'll understand why I use as few bars as possible.)

My signal only references data from the secondary symbol and has a Maximum number of bars the study will reference set to 50. This is more than how many bars are in the primary data series which is causing the signal not to start in Auto-Trading mode.

All I can say is I wish you would please change this unnecessary and confusing program behavior. There is no warning message which lets the user know why it didn't auto-start and yet the signal will run just fine if I start it manually.

User avatar
Anna MultiCharts
Posts: 461
Joined: 14 Jul 2017
Has thanked: 31 times
Been thanked: 113 times

Re: save autotrading status  [SOLVED]

Postby Anna MultiCharts » 01 Jun 2018

rrams,

we replicated this behavior on our end and understand your concern. We’ll introduce some kind of notification in further MultiCharts versions. Unfortunately I cannot give any ETA at the moment.


Return to “MultiCharts”