All Data Everywhere Timing Issue

Questions about MultiCharts and user contributed studies.
FATSTrader
Posts: 15
Joined: 14 Feb 2011
Has thanked: 7 times
Been thanked: 3 times

All Data Everywhere Timing Issue

Postby FATSTrader » 16 Jan 2012

Hi, I am using All Data Everywhere to share data between 2 charts in a workspace.
The issue I am having is the receiving chart is throwing an error as it cannot find
the ADE class. This is because it attempts to look for the class/data before it
is created by the sending chart. If I re-enable the study after a few seconds it's fine.

Is there a way to delay the processing of the receiving chart for a few seconds
until after the sending chart is complete? Perhaps a way to pause?

Appreciate any suggestions!

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 35 times
Been thanked: 12 times

Re: All Data Everywhere Timing Issue

Postby NiC72 » 17 Jan 2012

Try "RecalcLastbarAfter()".
For instance, "RecalcLastbarAfter(1)" will force the script to recalculate every second.

SP
Posts: 455
Joined: 06 Feb 2006
Has thanked: 36 times
Been thanked: 283 times

Re: All Data Everywhere Timing Issue

Postby SP » 18 Jan 2012

NiC72,

i have a similar problem with sending ADE values from the scanner to a chart as the chart loads faster and the scanner values arent calculated yet.

The problem is that if the indicator doesnt find the ADE Class the staus is turned to "off". A
RecalcLastbarAfter doesnt turn the status back to "on".

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 35 times
Been thanked: 12 times

Re: All Data Everywhere Timing Issue

Postby NiC72 » 18 Jan 2012

SP you are right .. Maybe use:

IsFile = ADE.FileExists(FileName);

Returns true if the specified file exists. ADE uses this function to check for the existence of a data file before attempting to load it.

evdl
Posts: 401
Joined: 19 Jan 2011
Location: Netherlands
Has thanked: 85 times
Been thanked: 123 times

Re: All Data Everywhere Timing Issue

Postby evdl » 04 Jun 2013

When starting MC every morning, the charts have to backfill the missing data first. Also some charts are available faster then others even without backfilling.

So every morning all strategies that use ADE are put to off because of the error message generate by ADE because of the class has no data yet, due to charts that are not available yet.

In this thread I saw the option to check for the existence of the ADE file. But I don't export the ADE values, there are all loaded in memory. So there is no file.

How can I delay the sending and receiving of all ADE values till after all the charts are backfilled and available. So I can avoid the error messages and manual reloading of my strategies.

Or is there a method I can use that will tell me if the chart is ready and available. In that way I can make this a condition for starting the ADE part in my strategies.

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: All Data Everywhere Timing Issue

Postby Henry MultiСharts » 05 Jun 2013

Hello evdl,

You can create a unique variable in each study that uses ADE. Each study using ADE should read the unique variables from all other charts using ADE and execute ADE code only after all other studies provide the variable values.

evdl
Posts: 401
Joined: 19 Jan 2011
Location: Netherlands
Has thanked: 85 times
Been thanked: 123 times

Re: All Data Everywhere Timing Issue

Postby evdl » 05 Jun 2013

I probably don't understand your solution Henry.

If I use ADE to send unique variabels to other charts and not all charts are available. Will that not also trigger errors and put the strategy to off, now because it can not find the unique variabel?

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: All Data Everywhere Timing Issue

Postby Henry MultiСharts » 06 Jun 2013

Here is what I mean:
Image
Attachments
ADE.PNG
(11.94 KiB) Downloaded 1601 times

evdl
Posts: 401
Joined: 19 Jan 2011
Location: Netherlands
Has thanked: 85 times
Been thanked: 123 times

Re: All Data Everywhere Timing Issue

Postby evdl » 06 Jun 2013

Thank you for the picture example. Much appreciated.

I will have to figure out, how to send the unique variabels between the charts. Maybe I try to use GV, this to avoid errors on ADE.

If I find a way to do this, I will post it here.


Return to “MultiCharts”