BETA-UDDE/Excel not displaying some quotes on chart

Questions about MultiCharts and user contributed studies.
Neolystic
Posts: 8
Joined: 28 Feb 2007
Contact:

BETA-UDDE/Excel not displaying some quotes on chart

Postby Neolystic » 04 Jun 2007

Quotes with decimal numbers are not displaying on charts from Excel through Universal DDE. Quotes with whole numbers display correctly. This problem can be recreated with the following steps:

1. Create a symbol using universal DDE connected to Excel. Make sure the symbol connection test passes.
2. Create a new chart in MC using this new symbol.
3. Enter '25' into the referenced Excel cell. This value displays correctly on the chart.
4. Enter '25.5' into the referenced Excel cell. This value does NOT show up on the chart.

The symbol can be set to realtime status 'online' in QM and both decimal and non-decimal numbers correctly increment the 'x received' indicator. However, only non-decimal numbers show up on a chart. I have played around with the symbol properties such as 'settings', 'sessions', etc. to no avail. This setup worked correctly in the previous non-beta version.

Thanks,
Neo

Neolystic
Posts: 8
Joined: 28 Feb 2007
Contact:

Postby Neolystic » 06 Jun 2007

As a follow-up - Further testing shows that this problem is not in the tsDDESupplier.dll file. I installed version 2.0.759.33153 of this dll (from MC version 2.0.777.777) into the new beta version and the problem still exists.

User avatar
Kate
Posts: 758
Joined: 08 Dec 2006

Postby Kate » 07 Jun 2007

I tried to reproduce the situation in the new beta and entered first 25 and then 25.5 into the referenced Excel cell. But both values were displayed correctly (please see the attached screenshots). Could you post some screenshots illustrating your point?
Attachments
DDE Excel.zip
(215.78 KiB) Downloaded 117 times


Return to “MultiCharts”