Wierd Error

Questions about MultiCharts and user contributed studies.
damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Wierd Error

Postby damageboy » 23 Jul 2007

I get the error "Unspecified Error" with the foloowing code:

Code: Select all

Inputs:
   UseFile(ADE.UseFile);     // default UseFile is returned by ADE.UseFile


If I comment the UseFile line it compiles fine...

Ade.UseFile is defined as follow (and compiles fine):

Code: Select all

// Modify this function to change the default value of UseFile in ADE indicators.

ADE.UseFile = true;


This is only with the NEW beta... I've recompiled everything already...
Any ideas MC team?

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 24 Jul 2007

Are you running 2.1.928.1050?
I tried to compile
Inputs:
UseFile(ADE.UseFile); // default UseFile is returned by ADE.UseFile

and it worked fine.
Could you send me full archive?

damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Postby damageboy » 24 Jul 2007

I have no problem with COMPILING it.
I have a problem with running.
I get "Unspecified error".

Other indicators (non-ADE) work fine.
All of my indicators compile... ( I recompiled after installation).
I am using the latest beta.

The two previous beta's released worked fine with ADE.
All I ever had to do it re-install + recompile.
Latest beta this changed for the bad.

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 24 Jul 2007

QA confirmed the problem. We will resolve it ASAP.

damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Postby damageboy » 24 Jul 2007

Thank you for responding quickly.

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 25 Jul 2007

You are welcome!

damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Postby damageboy » 28 Jul 2007

Is there an ETA for this bug fix?
I simply can't do anything without ADE... :)
I don't mine testing it out for you guys if you want to send me a dll...

damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Postby damageboy » 31 Jul 2007

Is there a way to revert to MC 2.1.909.909?
I simply can't use without my indicators...

miltonc4
Posts: 150
Joined: 14 Apr 2006
Has thanked: 1 time
Been thanked: 3 times

Postby miltonc4 » 11 Aug 2007

Hi MC support
I have the same problem with ADE as Damageboy reports

Version 2.1.928.1050

The below compiles OK and loads OK,but with the message "Unspecified error".

I have changed the function UseFile(ADE.UseFile); to True,but it still gives the same error

Milton



[LegacyColorValue = TRUE];

Inputs:
UseFile(ADE.UseFile); // default UseFile is returned by ADE.UseFile function

Vars:
Class("OHLCV"),
Vol(0),
WriteOk(true);

// If UseFile is true, load any previously stored data from the file on the first bar.
if CurrentBar = 1 and UseFile then
Value1 = ADE.OpenMap(Class, GetSymbolName, ADE.BarInterval);

// Calculate correct total volume regardless of bar type
Vol = IFF(BarType < 2, UpTicks + DownTicks, Volume);

// Store the data for this symbol and bar interval
Value1 = ADE.PutOHLCV(GetSymbolName, ADE.BarInterval, ADE.BarID, Open, High, Low, Close, Vol);

// If UseFile is true, save the data to the file on the last bar.
if LastBarOnChart and BarStatus(1) = 2 and UseFile and WriteOk then begin
Value1 = ADE.SaveMap(Class, GetSymbolName, ADE.BarInterval);
WriteOk = false; // prevent repeated writes on new bars
end;

Plot1(0); // include a Plot statement so we can use this indicator in RadarScreen

damageboy
Posts: 70
Joined: 15 Sep 2006
Been thanked: 14 times

Postby damageboy » 13 Aug 2007

@miltonc4: next beta release should fix that.
Don't know when it will be out, perhaps MC team will kindly post a REAL release date for the next beta... (I think it was supposed to be last Friday)

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 13 Aug 2007

Hello,

The problem is already fixed - the next MC version fixes that. As for the estimated time when the release will be available - it is postponed for about two weeks.

User avatar
Januson
Posts: 119
Joined: 18 Apr 2007
Location: Denmark

Postby Januson » 11 Oct 2008

Is damageboy not here anymore?


Return to “MultiCharts”