How can you remove the 3 decimal places in MC with the ES?

Questions about MultiCharts and user contributed studies.
User avatar
futurestrader019
Posts: 79
Joined: 14 Apr 2007
Has thanked: 1 time

How can you remove the 3 decimal places in MC with the ES?

Postby futurestrader019 » 08 Aug 2007

Sometimes on my charts the ES numbers will show 3 decimal places. There is obviously no need for there to be 3 decimal places on the ES. Is there a way to tell MC to always just use 2 decimal places on an ES chart?

Thanks!

Guest

Postby Guest » 08 Aug 2007

the decimal places are supplied by IB.
you can change the presentation in MC, but it is a pain to do.

right click on the chart to call up "format window".
under y-price scale... change the Manual [ ] char to whatever you want.

p.s. But my right most character is half hidden by the window frame. it might be a bug.

User avatar
futurestrader019
Posts: 79
Joined: 14 Apr 2007
Has thanked: 1 time

Postby futurestrader019 » 08 Aug 2007

I'm using Open ECry data to plug into MC, but thank you for the suggestion on how to change.

Nick
Posts: 490
Joined: 04 Aug 2006
Has thanked: 4 times
Been thanked: 24 times

Postby Nick » 08 Aug 2007

p.s. But my right most character is half hidden by the window frame. it might be a bug.


It is on mine too. I reported this a long long long time ago. There are a couple of places where there is a wee bit too much space too. (Wasting valuable screen real estate).

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 08 Aug 2007

Hello,

The number of decimals for a symbol is regulated through the settings in Quote Manager->Edit Symbol->Settings - Price Scale.

Nick, as for the window frame hiding the last character: could you send us a screenshot?

Guest

Postby Guest » 24 Aug 2007

When are you going to support changing the price scale of the y-axis to whatever the User wants?

For example, the 30 yr bond feed (ZBU7) via OpenECry has decimals instead of 32nds.

How do I convert this back into its native 32nds fractions?

And why is this such a pain for users to do?

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 24 Aug 2007

This feature will be realized in MultiCharts 2.2 due end of 2007.

User avatar
TJ
Posts: 7179
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 990 times
Been thanked: 2049 times

Postby TJ » 24 Aug 2007

see attached.
Half of the last digit is hidden behind the window frame.

MC 2.1.928.1050
(same problem with prev version)
Attachments
_hidden.PNG
_hidden.PNG (37.42 KiB) Viewed 959 times

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 27 Aug 2007

see attached.
Half of the last digit is hidden behind the window frame.

MC 2.1.928.1050
(same problem with prev version)


Hello,


When you set the number of charachters in Format Window-> Y-Price Scale -> Manual you tell the window to have room for 6 characters only. These six charachters include the decimal sign as well. In other words you only have enough room for 5 digits and a decimal sign. Whatever does not fit in gets cut off.

On the other hand, it is the settings in Quote Manager-> Edit Symbol -> Settings -> Price Scale that dictate how many characters after the decimal are to be displayed. If the chosen Price Scale is 1/100 the chart is supposed to display 2 digits after the decimal.

This conflict can be solved either by manually increasing the number of symbols to be displayed in the Format Window, or by choosing Automatic for this parameter.

Nick
Posts: 490
Joined: 04 Aug 2006
Has thanked: 4 times
Been thanked: 24 times

Postby Nick » 29 Aug 2007

Actually this is much better than it used to be. Its liveable with but still looks slightly off sometimes. In the old days I had to have every chart as manual with an extra character or two.

Now it looks like its not scaled on the widest numbers possible.

Here are a couple of YM charts both set to auto both with slightly different spacing. On the first is the current price 6 or 8? The second is fine (maybe too much space!)

No Biggy
Attachments
yscale.png
tight
yscale.png (31.3 KiB) Viewed 936 times
yscale1.png
lots of space
yscale1.png (71.07 KiB) Viewed 950 times

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 29 Aug 2007

That's right. This is a confirmed bug. When you choose "Automatic" in Format Window there should be enough room to display all the digits in the number. We are going to fix this bug in the future MC versions. For now, in cases when a character gets partly cut off you could adjust in manually.

Nick
Posts: 490
Joined: 04 Aug 2006
Has thanked: 4 times
Been thanked: 24 times

Postby Nick » 30 Aug 2007

Excellent,

As I said no big deal. The only thing I would add is don't add too much space! screen real estate is very valuable :)


Return to “MultiCharts”