Strange Issue with Ascii mapped data  [SOLVED]

Questions about MultiCharts .NET and user contributed studies.
robbob
Posts: 46
Joined: 26 Jan 2013
Has thanked: 2 times
Been thanked: 3 times

Strange Issue with Ascii mapped data

Postby robbob » 03 Feb 2014

Hi,
I'm using the "Map ASCII" option in Quote Manager to map a directory of ASCII files to 19 futures symbols. All the symbols appear to map correctly, except for heating oil.

When creating a chart for heating oil, the OHLC values appear to be mapped incorrectly, with the close price as the high price, which is illustrated by every candlestick being green. (screenshot attached).

The data in the file is formatted exactly the same was as the other commodity files (see below). Any idea what may be going on?


20140122, 2.95200000, 2.98470000, 2.95200000, 2.98120000, 155134, 283455
20140123, 2.98300000, 3.00330000, 2.97400000, 2.99100000, 157304, 286862
20140124, 2.99190000, 3.03360000, 2.95680000, 3.01580000, 175235, 289540
20140127, 3.02000000, 3.03180000, 2.95860000, 2.96670000, 183070, 282860
20140128, 2.96750000, 2.99910000, 2.95760000, 2.99390000, 157220, 283200
20140129, 2.99830000, 3.02360000, 2.98390000, 3.02040000, 162585, 284121
20140130, 3.02360000, 3.04170000, 3.00740000, 3.02750000, 134488, 279206
20140131, 3.03750000, 3.05900000, 2.99100000, 2.99710000, 165320, 279206
Attachments
screenshot.png
screenshot.png (96.95 KiB) Viewed 571 times

User avatar
Henry MultiСharts
Posts: 9093
Joined: 25 Aug 2011
Has thanked: 1258 times
Been thanked: 2923 times

Re: Strange Issue with Ascii mapped data  [SOLVED]

Postby Henry MultiСharts » 03 Feb 2014

Hello robbob,

In ASCII Mapping window please click on the file you are having problem with, in the appeared ASCII data import window please redefine the data columns/fields the way you need it.

robbob
Posts: 46
Joined: 26 Jan 2013
Has thanked: 2 times
Been thanked: 3 times

Re: Strange Issue with Ascii mapped data

Postby robbob » 03 Feb 2014

Hi Henry,

I've tried to map the fields to Open/High/Low/Close/Volume/Open Interest in the ASCII data import window for the problem file, but the problem still persists. I've tried clearing the cache and refreshing in the Quote Manager, and also tried refreshing the chart as well as creating a new chart in the workspace, but the chart still looks the same.

Thanks,
-Rob

robbob
Posts: 46
Joined: 26 Jan 2013
Has thanked: 2 times
Been thanked: 3 times

Re: Strange Issue with Ascii mapped data

Postby robbob » 03 Feb 2014

Hi Henry,

I've created a brand new symbol and that seems to have taken care of the issue.

Thanks,
-Rob


Return to “MultiCharts .NET”