Problem with 5.5 beta 4

Questions about MultiCharts and user contributed studies.
Phil Pw
Posts: 16
Joined: 03 Jul 2009

Problem with 5.5 beta 4

Postby Phil Pw » 09 Aug 2009

I think I found a problem in the porfolio backtester.

My drawdown his -322742.33$

phil pw
Attachments
portfolios max.png
portfolios max.png (143.44 KiB) Viewed 154 times

User avatar
TJ
Posts: 6521
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 957 times
Been thanked: 1883 times

Postby TJ » 09 Aug 2009

have you looked at the equity curve?

can you post that graph as well?

Phil Pw
Posts: 16
Joined: 03 Jul 2009

Postby Phil Pw » 09 Aug 2009

Are you go

phil pw
Attachments
portfolios max1 curve.png
portfolios max1 curve.png (275.52 KiB) Viewed 142 times

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 10 Aug 2009

Please post a screenshot of
"Equity Curve Detailed With Drawdown" chart.
Close 2 Close Drawdown doesn't take into account opened positions.
We suspect there were a bid tick with 0 value on some bar and you had quite large number of contracts. The next bar was good and the position opened with profit or small loss.
We need more ifnroamtion.

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 10 Aug 2009

Please save your report in Excel format and send us.

Phil Pw
Posts: 16
Joined: 03 Jul 2009

Postby Phil Pw » 10 Aug 2009

Hi andrew, this is my 1 year trade porfolios data. It was taking too much time to do 10 years
Attachments
Portfolio Performance Report.xls
(530.67 KiB) Downloaded 37 times

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 10 Aug 2009

We do think this is a bug, but we can't reproduce it on standard studies. Could you try to reproduce it on some standard studies and send us wsp +signal. If you can't could you send us your strategy in SEF format and WSP just to see the problem.

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 12 Aug 2009

The bug is confirmed. It has been introduced in MC 5.5 Beat 1. It will be fixed in the next beta.


Return to “MultiCharts”