Incorrect timestamps - possible daylight saving issue

Questions about MultiCharts and user contributed studies.
janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Incorrect timestamps - possible daylight saving issue

Postby janus » 28 Mar 2010

Something very strange happened to me today. The chart of a symbol wasn't being updated in real-time despite the fact it was showing up fine on IB's tws screen. When I looked at the actual data in the database using QM, the timestamps were offset by 1 hour, only for today. This explained why it wasn't being plotted as it was outside the session time. Now, I thought this was a daylight saving issue. However, I checked and daylight saving has not changed over this weekend. So, I went into QM -> Tools -> Exchanges & ECNs -> Time zone to see what the timezone setting was. It looked fine as it was using "From Systems Options" and was set to the correct time zone. So, I started thinking it was IB's fault since I was using Server Timestamps for real-time mode. I switched it off, re-loaded the data but no change. So, I then went back to QM > Tools -> Exchanges & ECNs -> Time zone, clicked on "Custom" then clicked back to "From Systems Options", saved, re-loaded the chart and it was all fine. The data in the database also now showed the correct timestamps. I now switch back to Server Timestamps for real-time mode and still it's fine.

Something to watch out for. Anyone else had this problem? This occurred on a Windows XP SP2 platform. System time was always showing the correct time. I might try it later on my Vista one.

User avatar
geizer
Posts: 375
Joined: 16 Jun 2008
Has thanked: 40 times
Been thanked: 38 times

Postby geizer » 28 Mar 2010

Microsoft has released a number of time zone updates for Windows XP since the release of SP2.

janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Postby janus » 28 Mar 2010

Microsoft has released a number of time zone updates for Windows XP since the release of SP2.


All applied a few weeks ago. It doesn't explain how it fixed itself though. It's still working fine. Perhaps I had to cycle the Exchanges & ECNs -> Time zone setting in QM as I explained to pick up the Microsoft updates. Just guessing.

tekram
Posts: 96
Joined: 26 May 2009
Has thanked: 6 times
Been thanked: 18 times

Postby tekram » 29 Mar 2010

This could be a problem even with Winxp sp3 which did not include the DST patch from 2007, 2008. There is a third party patch daylightsavingfix.exe that will do the job if one chooses not to do the MS update route.

The result in MC could be that the chart not updating by one hour from open. Applying the patch and reset the symbol alone did not correct the error. Only recreating a new chart fixed the updating problem, in this case AD-NYSE bid/ask from IB data.

Image
Attachments
IBDaylightsavingsPatch_Charterror.gif
IBDaylightsavingsPatch_Charterror.gif (31.04 KiB) Viewed 198 times


Return to “MultiCharts”