Strange Backtesting results in Multicharts

Questions about MultiCharts and user contributed studies.
User avatar
t-rader
Posts: 139
Joined: 02 Feb 2011
Location: Australia
Has thanked: 11 times
Been thanked: 27 times

Strange Backtesting results in Multicharts

Postby t-rader » 22 Feb 2011

Hi,

I am currently backtesting my first forex system in the Portfolio Backtester application and have noticed the backtest results are completely different than what is displayed on my chart.

The trade times and prices simply don't match. Why is this? On the chart I have enabled bar magnify and set it to intra-day 1 minute. I have also set my chart and backtest timezone to local. Instrument is EUR/USD set to 1 hour resolution. My demo trading account is from MB Trading.

I have also noticed that my backtesting is only going back from today (22 Feb 2011) to August 2010, even though I set it to 300 days. The Multicharts website says MB Trading provides data feed for "1 year of minute bars". Doesn't this mean I should see 300 days worth of results through Portfolio Backtester?

Regards
T

Roumeau
Posts: 18
Joined: 18 Nov 2010

Re: Strange Backtesting results in Multicharts

Postby Roumeau » 22 Feb 2011

Very strange me too...

I used to make a lot of opti on MC and implement strat in a portfolio.

Usually all my BT match but today... awfull results, no one match, my portfolio bt is nonsense...

I was afraid when I saw in this forum t-rader is in the same situation.

I use MBT demo account but daily datas since 2000.

Any tips on this problem??

Roumeau
Posts: 18
Joined: 18 Nov 2010

Re: Strange Backtesting results in Multicharts

Postby Roumeau » 22 Feb 2011

I think I have a start a answer.

The difference between Portfolio and MC BT is due to (for me) big point value in QM.

Let me explain (a little bit difficult, ach)

I develop my strategies with a BPV of 10000 for EURUSD for ex., in order to trade into mini-contracts. In my strat, I have an input called lotSize, which value is one for a contract of 10000.
for example: Buy ( "toto" ) LotSize contract next bar on Open;

I want to join MB Trading and I had to set the BPV to 1.
So, in order to trade a mini-contract, I set my lotSize to 10000.
No problem on backtesting on MC, the before and after setting BPV and lotSize is the same.

But..... with BPV to 1 and lotSize 10000 is absolutely not the same for the backtesting in Portfolio compare to BPV to 10000 and lotSize to 1! (I made the test this night)

Members or MC staff any ideas about this problem? Is this a wellknown issue?

In order to perform my Portfolio BT, I will create 2 sets of datas, datas for live trading with MBT with BPV 1, and set of datas for Portfolio Backtesting, with BPV to 10000, but it is not very confortable... :-(

Thank u all,

Regards.

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 487 times

Re: Strange Backtesting results in Multicharts

Postby Dave Masalov » 14 Mar 2011

Members or MC staff any ideas about this problem? Is this a wellknown issue?
Probably LotSize parameter is used incorrectly. Please send us your signal, Portfolio workspace as well as screenshots showing the issue to dmasalov@multicharts.com for further investigation.

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 487 times

Re: Strange Backtesting results in Multicharts

Postby Dave Masalov » 14 Mar 2011

I am currently backtesting my first forex system in the Portfolio Backtester application and have noticed the backtest results are completely different than what is displayed on my chart.
Dear t-rader,

Firstly, Portfolio Backtester does not have Bar Magnifier feature. Secondly, the calculation of the number of the contracts that your signal can buy for the available capital is more intellegent in Portfolio Backtester.


Return to “MultiCharts”