ASCII Mapping - Missing last bar

Questions about MultiCharts and user contributed studies.
User avatar
JoshM
Posts: 2089
Joined: 20 May 2011
Location: The Netherlands
Has thanked: 1525 times
Been thanked: 1485 times
Contact:

ASCII Mapping - Missing last bar

Postby JoshM » 18 Feb 2012

I have the following data in a text file:

Code: Select all

20120215;060000;79,13;79,64;78,95;79,58;1
20120216;060000;79,41;79,74;79,1;79,67;1
20120217;060000;79,75;80,12;79,27;79,35;1
20120218;060000;79,39;79,48;79,15;79,33;1


Symbol mapping works correctly, except for displaying the last bar for instruments in a different time zone.

I've tried the following:
    * Removed all symbol mappings and remade then,
    * Applying other sessions templates: 24/5, 24/7, Default, American market, American Market with pre- & post hours
    * Setting the time zone of the chart to exchange, then retry the mentioned session templates.
    * Changing the DateTime format of the import to my time zone.
    * Closed MultiCharts and restarted it.

None of this helped. However, since the problem only occurs with instruments in another time zone. Which suggests to me that a) MultiCharts have no problem ASCII mapping and that b) I know how to setup ASCII mapping.

Also, the ASCII Data import window can read the last line with the last close when I set the ASCII mapping settings:
Image

However, the chart still displays yesterday's value:
Image

Didn't knew that making a chart would be so difficult and time consuming. :)

Anyone got an idea? I must be overlooking something very obvious.
Attachments
scr.18-02-2012 11.12.41.png
scr.18-02-2012 11.12.41.png (1.19 KiB) Viewed 175 times
scr.18-02-2012 11.09.45.png
scr.18-02-2012 11.09.45.png (10.53 KiB) Viewed 170 times

User avatar
Henry MultiСharts
Posts: 8511
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2733 times

Re: ASCII Mapping - Missing last bar

Postby Henry MultiСharts » 21 Feb 2012

Hello Josh,

Please make sure that the trading session has already started.
If you still have the issue:
Please let me know the exact version and build of MultiCharts you are running,
attach the file you are mapping,
attach the screenshot of the session settings you have set for the instrument,
what is your time zone?
These users thanked the author Henry MultiСharts for the post:
JoshM

User avatar
JoshM
Posts: 2089
Joined: 20 May 2011
Location: The Netherlands
Has thanked: 1525 times
Been thanked: 1485 times
Contact:

Re: ASCII Mapping - Missing last bar

Postby JoshM » 22 Feb 2012

Thanks for your reply Henry.

While responding to your message Henry I looked to check the exchange settings, and saw that the 'ICE' exchange is not the ICE exchange on which the DX trades but the Iceland Stock Exchange.

I've corrected that error now (set to NYSE since I couldn't find the ICE) and will see the coming weekend if it's definitely is corrected.
These users thanked the author JoshM for the post:
Henry MultiСharts

User avatar
Henry MultiСharts
Posts: 8511
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2733 times

Re: ASCII Mapping - Missing last bar

Postby Henry MultiСharts » 22 Feb 2012

Josh,

We have renamed "Iceland Stock Exchange" into "ICEI" and added correct "ICE" that is "Intercontinental Exchange" in MultiCharts 7.0
NYSE settings are different from ICE.
Please make sure that you are using the correct settings.
Attachments
ICE.png
ICE.png (36.36 KiB) Viewed 111 times


Return to “MultiCharts”