question for IQFeed users  [SOLVED]

Questions about MultiCharts and user contributed studies.
User avatar
arnie
Posts: 1593
Joined: 11 Feb 2009
Location: Portugal
Has thanked: 481 times
Been thanked: 511 times

question for IQFeed users

Postby arnie » 22 Jan 2013

For you that have IQFeed as data source, when you open a RTH chart using @ES#C symbol, do you get a profile for yesterday?

Image
Attachments
es_c.png
es_c.png (32.74 KiB) Viewed 901 times

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: question for IQFeed users

Postby Andrew MultiCharts » 23 Jan 2013

Hello Arnie,

Can you reproduce the issue with the latest VolumeProfile.dll file?
What data is used for Volume Profile: asks and bids / trades?

User avatar
arnie
Posts: 1593
Joined: 11 Feb 2009
Location: Portugal
Has thanked: 481 times
Been thanked: 511 times

Re: question for IQFeed users

Postby arnie » 23 Jan 2013

Andrew MultiCharts wrote:Hello Arnie,

Can you reproduce the issue with the latest VolumeProfile.dll file?
What data is used for Volume Profile: asks and bids / trades?


Unfortunately yes.

Image

I'm having a lot of problems with this symbol.
Last week I probably spent like 3 hours with Katrin because of it.

Waiting for your tests...
Attachments
VP_nodata.png
VP_nodata.png (81.11 KiB) Viewed 624 times

sptrader
Posts: 710
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 468 times
Been thanked: 261 times
Contact:

Re: question for IQFeed users

Postby sptrader » 23 Jan 2013

The symbol that I use on IQfeed is @ES# .. Looks OK to me.
Attachments
ES_Vol Profile-1-23-13.png
ES_Vol Profile-1-23-13.png (89.26 KiB) Viewed 553 times

User avatar
arnie
Posts: 1593
Joined: 11 Feb 2009
Location: Portugal
Has thanked: 481 times
Been thanked: 511 times

Re: question for IQFeed users

Postby arnie » 23 Jan 2013

sptrader wrote:The symbol that I use on IQfeed is @ES# .. Looks OK to me.


Yes, that symbol is OK. Is the one I'm using now.
The symbol @ES#C is the back-adjusted one.

For some reason this symbol has been a problem almost from day one when I started to test MC 8.5.

SP
Posts: 453
Joined: 06 Feb 2006
Has thanked: 36 times
Been thanked: 283 times

Re: question for IQFeed users

Postby SP » 24 Jan 2013

Arnie,

as the monday was Martin Luther holiday and you get the data only displayed if you have unchecked "Do not use holidays" in the QM, could it be that the code does not recognize sessionstarttime and sessionendtime correctly at the ES#C as there was no classic RTH trading ?

User avatar
arnie
Posts: 1593
Joined: 11 Feb 2009
Location: Portugal
Has thanked: 481 times
Been thanked: 511 times

Re: question for IQFeed users

Postby arnie » 24 Jan 2013

SP wrote:Arnie,

as the monday was Martin Luther holiday and you get the data only displayed if you have unchecked "Do not use holidays" in the QM, could it be that the code does not recognize sessionstarttime and sessionendtime correctly at the ES#C as there was no classic RTH trading ?


Actually there's nothing wrong in terms of studies.
My studies work fine on both symbols. The problem is just with the profile.
I've reloaded the chart many times, created new charts, but I can't get any data for that day. As you can see, there's no delta also.

Now I'm assuming this is an IQFeed problem and not MC's.

Image
Attachments
holiday.png
holiday.png (37.95 KiB) Viewed 607 times

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: question for IQFeed users  [SOLVED]

Postby Andrew MultiCharts » 25 Jan 2013

Arnie, the issue is fixed. Should be working fine in coming MultiCharts 8.5 Release version.


Return to “MultiCharts”