Newbie Questions

Questions about MultiCharts and user contributed studies.
User avatar
Pete Mimmack
Posts: 3
Joined: 19 Aug 2006

Newbie Questions

Postby Pete Mimmack » 19 Aug 2006

(edited to reduce verbage as I put the pieces together).

A friend has challenged me to code my Trading Plan, so I've downloaded the demo and grabbed the EL doc from TS.com. With 20 yrs of SW dev and a pretty good knowledge of charts, this could be fun. But, sometimes you need to ask stupid questions, so here we go.

1) Is the demo version fully featured and documented? There seem to be some gaps. E.g., EL doc discusses "strategies" at length, but I see almost no references to them in MC doc.
ANSWER: Found a post where a Strategy = 1 or more signals. Fine.
Q Still: Is there more doc than what's in the Help?


1b) (later that nite .... verbage)
PARTIAL ANSWER: I see that Signals are enabled in the Beta PLeditor.
Q Still: Do signals only work in real time, and maybe backtesting?

2) Is PLEditor supposed to close itself periodically? It's possibly related to having an open window on a Study that's been added to a chart, but I think I've seen it other times as well.

3) I laugh at every semi-colon: is this really just a C pre-processor that Marketing had the nerve to call "Easy" ?!

Pete
Last edited by Pete Mimmack on 20 Aug 2006, edited 2 times in total.

User avatar
Pete Mimmack
Posts: 3
Joined: 19 Aug 2006

Postby Pete Mimmack » 19 Aug 2006

Here's a simple one: Can I create a 2 symbol chart with the demo version, and how?

Help screens basically just say, "Open dialog windows and click Add", but when I do that I get, "Please run QM to add the symbol manually." QM is running in another window in this workspace, and the symbol is there. In fact, I clicked on it from the symbol list in Format Symbol, thinking that might add it, but it replaced the one that I had there. So its data is accessible, which suggests that the "run QM" message is out of place: I'm trying to add the symbol to this chart, not the workspace.

Thanks.

BTW, I'll probably be plunking down the Big Bucks as it looks like this has the ability to do what I want. But it will be nice to get a little closer to actually doing it before opening the wallet.

User avatar
Alex Kramer
Posts: 834
Joined: 23 Feb 2006

Postby Alex Kramer » 21 Aug 2006

1) Is the demo version fully featured and documented? There seem to be some gaps. E.g., EL doc discusses "strategies" at length, but I see almost no references to them in MC doc.
ANSWER: Found a post where a Strategy = 1 or more signals. Fine.
Q Still: Is there more doc than what's in the Help?

We're working on developing complete and detialed documentation to include all the new aspects of PowerLanguage but so far we have to recommend referring to Easy Language documentation.

1b) (later that nite .... verbage)
PARTIAL ANSWER: I see that Signals are enabled in the Beta PLeditor.
Q Still: Do signals only work in real time, and maybe backtesting?

Signals should be working bot in relaltime data and backtesting, please contact us if you're having issues with some certain case.

2) Is PLEditor supposed to close itself periodically? It's possibly related to having an open window on a Study that's been added to a chart, but I think I've seen it other times as well.

Please tell more if this keeps occuring, we'll need more information - this should not be occuring, MultiCharts and PLEditor are functioning as separate applications.

3) I laugh at every semi-colon: is this really just a C pre-processor that Marketing had the nerve to call "Easy" ?!

I'm afraid this question is better addressed to TS - what we aimed for is total compatibility with EasyLanguage, which as languages go is easy - it is defininitely possible to write indicators with little learning.

Here's a simple one: Can I create a 2 symbol chart with the demo version, and how?

Have both symbols added in QuoteManager. Plot a chart of the first symbol, right-click chart, in the menu select Insert Symbol. A new Format Symbol dialog opens, select the required second symbol in it and choose its settings.

User avatar
Pete Mimmack
Posts: 3
Joined: 19 Aug 2006

Postby Pete Mimmack » 21 Aug 2006

Alex -

Signals work as expected in the Beta. Good to see.

The PLeditor exit was sporadic, and never when I was in it, but if I ever find a pattern to it, will send you details.

I've been able to add a 2nd symbol in the beta. I was thrown off by selecting a symbol in the Format Symbols box and having it become the only symbol listed under the ALL tab. When I did this in the demo, it became the only symbol on the chart, but in the Beta, clicking OK now adds it to the chart. (Which I expected to be the function of the Add Symbol button, but apparently not.)

Thanks

User avatar
Alex Kramer
Posts: 834
Joined: 23 Feb 2006

Postby Alex Kramer » 22 Aug 2006

Glad I was able to help with the interface; if you're still having the PLEditor closing issue, please keep us informed, we're very interested in this. So please write or post here if this happens and describe what were you diong at the moment, what kind of code did you have open in PLEDitor, etc. - details will be most appreciated.


Return to “MultiCharts”