Imported TS strategies

Questions about MultiCharts and user contributed studies.
Posts: 4
Joined: 21 Aug 2006

Imported TS strategies

Postby gaspard » 21 Aug 2006

xxx.872 Beta:
I have imported strategies from TS. They compiled successfully, but nevertheless I cannot get signals to appear on a chart; they work well on the same symbols in TS. The performance report shows 0 trades.

I have found a workaround to make the signals appear: if I write and compile a simple strategy (generates just 1 trade) in PLEditor the signals from the imported TS strategy suddenly show up as well. But as soon as I remove the added simple strategy all signals disappear.

When applying built-in studies (e.g. Bollinger band LE) I also have problems: only the first trade appears on the chart. But as soon as I add another strategy all signals for both strategies appear.

This would appear to be a bug in the software.

Otherwise I am impressed by the stability and ease-of-use of the beta. It has not crashed on me once the past weeks.

User avatar
Alex Kramer
Posts: 834
Joined: 23 Feb 2006

Postby Alex Kramer » 21 Aug 2006

Could you please send the strategies that cause this issue?

Normally there's no problems getting signals to appear and the performance report shows a meaningful number of trades.

As to the Bollinger Bands situation, we think that if you're applying short or long signals only and the settings include only one entry in one direction (no pyramiding), there is just one entry and nothing else happenins untill you add more signals so and the position begins reversing.

Return to “MultiCharts”