Offline data mode for IB access

Questions about MultiCharts and user contributed studies.
GD
Posts: 20
Joined: 03 Apr 2006

Offline data mode for IB access

Postby GD » 14 Oct 2006

Is this not working now. I have the latest beta version, and this functionality seems to have disappeared. I used to be able to work offline w/o connecting to IB, but now it demands an IB login - even when set to offline mode.

I'm trying to access my local historical ES futures data on Saturday when IB is down, but it won't access the local data without establishing a connection with IB.

Does anyone know if something changed?

Thanks,

GD

momentum
Posts: 315
Joined: 23 Nov 2005
Has thanked: 8 times
Been thanked: 14 times

Postby momentum » 14 Oct 2006

I had the same problem but the work around is to change the end date of the request to the last date that you have data for. Just flies in then.

GD
Posts: 20
Joined: 03 Apr 2006

Postby GD » 14 Oct 2006

Ok, thanks. Good idea. Actually, though, I just went to try your suggestion, and it worked as it is supposed to - it retrieved my data w/o logging in before I had a chance to modify the symbol format. Very weird. I'll watch it to see if this inconsistency remains.

Alex et al, the only difference was that this time, I fired up when the mode was already set to the Offline preference. Previously, I fired up with Online - get missing data as the current preference, then switched to Offline, then tried to load the workspace. I wonder if that's related to the problem.

GD

User avatar
TJ
Posts: 6553
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 966 times
Been thanked: 1893 times

Postby TJ » 14 Oct 2006

I had the same problem.

I started MC... chose "Off-line" data at the dialogue box.

I loaded the wsp... then MC popped open my IB log-in. I guess it is looking for live feed.

I have to shut down MC and restart it... then the wsp would load up from off-line data.

User avatar
Alex Kramer
Posts: 834
Joined: 23 Feb 2006

Postby Alex Kramer » 16 Oct 2006

Dear users -
This is a known issue with updating the data server settings. You came up with the right solution - the application needs to be restarted for the changes to take effect. Sorry for the inconvenience, this will be fixed.

templ
Posts: 86
Joined: 19 Nov 2006
Has thanked: 2 times
Been thanked: 2 times

Postby templ » 02 Dec 2006

Dear users -
This is a known issue with updating the data server settings. You came up with the right solution - the application needs to be restarted for the changes to take effect. Sorry for the inconvenience, this will be fixed.


Is it fixed now?

I work in offline mode but, MC tries to connect to IB, if I change my chart resolution. (beta .1126)

User avatar
Stanley Miller
Posts: 556
Joined: 26 Jul 2005
Has thanked: 3 times

Postby Stanley Miller » 03 Dec 2006

Is it fixed now?

I work in offline mode but, MC tries to connect to IB, if I change my chart resolution. (beta .1126)


It has been already fixes a long ago and it shouldn't happen anymore. Could you please post the log files of QuoteManager generated when you work in offline mode and MultiCharts tries to connect to IB?

templ
Posts: 86
Joined: 19 Nov 2006
Has thanked: 2 times
Been thanked: 2 times

Postby templ » 05 Dec 2006

Could you please post the log files of QuoteManager generated when you work in offline mode and MultiCharts tries to connect to IB?


Maybe it has to do, that in my Quotemanager were some symbols in realtimemode?

Where is the file located and how it is called?
I only found this MsiDiffTool.log but it was empty.
In C:\Program Files\TS Support\Logs the folder was also empty.

In the screenshot are eventlogs
Attachments
offline_mode2.JPG
offline_mode2.JPG (75.5 KiB) Viewed 305 times


Return to “MultiCharts”