PLEditor - Stochastic Indicator Can not Compile

Questions about MultiCharts and user contributed studies.
neurotrader
Posts:86
Joined:29 Dec 2005
Location:CANADA
Contact:
PLEditor - Stochastic Indicator Can not Compile

Postby neurotrader » 18 Feb 2006

I have imported a few of my ela indicators into PLEditor and some can not be compiled. One example is the Stochastic-Metastock indicator which worked well in other Omega Products. The PLEditor imported the indicator and function fine, but when trying to compile it generated errors. This indicator exists in my systems also which would make the systems not work when signals and optimization is implemented. After import, below is copy and paste from PLEditor. ---------------------------------------------------------------

Input: KPeriods(5),DPeriods(3),KSlow(3),Sellzone(80),Buyzone(20);

%K(METAK(KPeriods,Kslow),"%K");
Plot2(Average(METAK(KPeriods,Kslow),DPeriods),"Plot2");
Plot3(Sellzone,"Plot3");
Plot4(Buyzone,"Plot4");

Please wait ....
------ Compiled with error(s): ------

errLine 3, errColumn 0, errLineEnd 3, errColumnEnd 0

User avatar
Stanley Miller
Posts:556
Joined:26 Jul 2005
Has thanked: 3 times

Postby Stanley Miller » 18 Feb 2006

Dear neurotrader,

You can't use % in the name of functions. Please let me know if this makes sense.

neurotrader
Posts:86
Joined:29 Dec 2005
Location:CANADA
Contact:

Postby neurotrader » 18 Feb 2006

I have just imported many of my created ela's from my older software into MC and many still can not be compiled. What I may have to do is re write all which would be very time consuming and a pain. Will see .. Thanks for the response

User avatar
Andrew Kirillov
Posts:1589
Joined:28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 18 Feb 2006

Dear neurotrader,

Your code as it shown here can be used neither with TS2000i nor TS8. According to the logic of your indicator you should change %K(METAK(KPeriods,Kslow),"%K"); for Plot1(METAK(KPeriods,Kslow),"%K");

neurotrader
Posts:86
Joined:29 Dec 2005
Location:CANADA
Contact:

Postby neurotrader » 18 Feb 2006

I just found out the problem when I imported my old ELA's ..in the example I gave you, the %K should have been imported as Plot1 .. So changing the %K to plot1 and compiling works ..Now to figure out the other imported ela's.. Perhaps similar? .. we see .. The ela's I m importing are from two omega products .. one is supercharts 4.0 RT .. other is TS

neurotrader
Posts:86
Joined:29 Dec 2005
Location:CANADA
Contact:

Postby neurotrader » 18 Feb 2006

We cross posted .. Your previous post was correct .. A few other ela's I imported I had to change some of the imported values to read Plot1 .. So far so good.

On another matter, do you have an idea when the Signal function will be available? .. days? weeks? months? ... thanks... I really do like what you have done so far with this software and once I figure things out with my old ela and signal transfers. I can't wait to use it as a trading platform. Since I trade during the day, the only time I have to evalute is on weekends although I did check it during the week with IB and love the ability to get historical from IB going back to begining of contract.

User avatar
Andrew Kirillov
Posts:1589
Joined:28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 22 Feb 2006

Dear neurotrader,

I can not give you exact signals release date. I beleive you will be able to work with some part of your signals in 6-8 weeks.


Return to “MultiCharts”