Easy Lang Study not working

Questions about MultiCharts and user contributed studies.
sinrswim
Posts:7
Joined:01 Mar 2006
Easy Lang Study not working

Postby sinrswim » 17 Mar 2006

I am trying to use the Easy Language indicator VolumeUpDown, however when I place it on a chart, it plots nothing. My only guess is DailyVolumeUp and DailyVolumeDown must be coming from TS, which I am no longer using as a feed. I am using Esignal as my feed.

Here is the TS code.

inputs:
DiffOrRatio_1or2( 1 ) ; // set to 1 for Up-Dn difference, 2 for Up/Dn ratio

variables:
UpDivDn( 1 ),
UpMinusDn( 0 ) ;

if GetAppInfo( aiRealTimeCalc ) = 1 then { real-time tick - not on bar in history }
begin
if DiffOrRatio_1or2 = 1 then
begin
UpMinusDn = DailyVolumeUp - DailyVolumeDn ;
Plot1( UpMinusDn, "UpDn" ) ;
Plot2( 0, "Baseline" ) ;
end
else if DiffOrRatio_1or2 = 2 then
begin
if DailyVolumeDn <> 0 then
UpDivDn = DailyVolumeUp / DailyVolumeDn ;
Plot1( UpDivDn, "UpDn" ) ;
Plot2( 1, "Baseline" ) ;
end
else
RaiseRunTimeError( "DiffOrRatio_1or2 input must be 1 or 2." ) ;
end ;

Chris
Posts:150
Joined:17 Nov 2005

Postby Chris » 18 Mar 2006

This is taken from the code header:

{ Plots the difference or ratio (user choice) of the cumulative up and down volume
for the day so far. For use with "live" market data only (the server fields used in
this indicator do not have stored history so will not be plotted on historical
bars). }

Maybe this is the problem - no live data. If I aplly the indicator to TS now, I don't see any results, too.

Chris

sinrswim
Posts:7
Joined:01 Mar 2006

Postby sinrswim » 18 Mar 2006

Yes, this has to be run in a live market, but it does not work during the trading day.

User avatar
Alex Kramer
Posts:834
Joined:23 Feb 2006

Postby Alex Kramer » 20 Mar 2006

A new version (1.90.442.1230) is now available, the problem with studies not compiling has been addressed in it.

The download link is, as always:

http://tssupport.com/products/multichar ... charts.exe

sinrswim
Posts:7
Joined:01 Mar 2006

Postby sinrswim » 05 Apr 2006

Hi Alex,,,

I tried using this study with version 1.90.442.1230 and it still does not work. I get nothing but a flat line for the indicator. I am using esignal as a feed. Any ideas why it is still not working?

Thnx,,Chris

User avatar
Alex Kramer
Posts:834
Joined:23 Feb 2006

Postby Alex Kramer » 06 Apr 2006

Sorry for disappointing you, but the functionality of DailyVolumeUp - DailyVolumeDn has not been implemented yet in MultiCharts.


Return to “MultiCharts”