How to Install or Update MultiCharts

From MultiCharts
(Redirected from How to Update MultiCharts)
Jump to navigation Jump to search

First installation

  1. Download the installer
    MultiCharts
    MultiCharts .NET
  2. Temporarily disable your antivirus/firewall software or whitelist MultiCharts processes. We recommend the latter.
  3. Run the downloaded installer.
  4. Wait for the installation to finish.

Upgrade

  1. Download the installer
    MultiCharts
    MultiCharts .NET
  2. Close all MultiCharts components and make sure there are no MultiCharts processes left in Task Manager -> Details tab -> Description column
  3. Temporarily disable your antivirus/firewall software or whitelist MultiCharts processes. We recommend the latter.
  4. Do a backup to keep your data safe
  5. Run the downloaded installer.
    There’s no need to uninstall the version you currently have, the newer one will overwrite it keeping all your user data and settings as is.
  6. Wait for the installation to finish.
    Depending on the amount and complexity of user data, the installation might take some time. Do not interrupt it to avoid installation errors.

Troubleshooting

The downloaded installer is “Unconfirmed”

Your browser blocked the download. You need to allow your browser to keep it:

  1. Go to your browser (Edge, Chrome, Firefox, etc.)
  2. Click the three dots in the top right corner of the browser window to open options
  3. Click Downloads, the Downloads window will open up
  4. Find the MultiCharts file. There should be “Keep”. Click it to allow the download.

The installer doesn't start

If you double-click the downloaded installer, but nothing happens, right-click it → Properties → General tab.
Check the Unblock box to avoid your system blocking the installer.

0x800c000e - Error downloading … A security problem occurred.

MultiCharts requires .NET Framework 3.5, 4.0 and 4.6.1 for correct operation. If they cannot be installed automatically, you’ll get the above message.
In that case, you’ll need to install/enable them manually: Windows Start > Settings > Apps > Programs and Features > Turn windows features on or off > check .NET Framework 3.5 and 4.6.1 (or newer)
If you're running MultiCharts on a server: Server Manager -> Manage -> Add Roles and Features -> in Installation Type tab select "Role-based or feature-based installation" -> Features -> check .NET Framework 3.5 and 4.6.1 (or newer)