+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
feature_request_small.png
Open Feature request MC-1607

Missing Data on Time Chart

action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

When I have a time chart plotting in real-time and i lose data feed connection and some time passes, when i reconnect the time chart loses whatever data occurred during the period when the data feed was disconnected. a volume chart will repopulate the new data correctly with no gaps when the data feed is reconnected. but as you can see in the attachment, time charts for whatever reason lose data. The missing data reappears correctly if the chart is simply copied and pasted into a new window. This is problematic for me because my custom indicators don't plot correctly when using the cut-n-paste solution.

Steps to reproduce this issue

plot a time chart, disconnect the data feed without closing down MC, then reconnect the data feed. this missing gap should be replicated on the original chart that lost the data feed.

Comments (1)
#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Feb 28, 2014 - 08:52

The feature indeed works no only for tick-based charts. We tried to implement it for all other chart resolutions, but faced some negative feedback ( http://www.multicharts.com/discussion/viewtopic.php?f=1&t=45490#p98980 and http://www.multicharts.com/discussion/viewtopic.php?f=19&t=45491#p98996)) and postponed the feature for a future version of MC.

History
Issue basics
  • Type of issue
    Feature request
  • Category
    Usability
  • Targeted for
    Not determined
  • Status
    Postponed
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (2)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    Not determined
  • Severity
    Normal
Attachments (1)
  • /pm/public/files/show/640
    Missing Data on Time Chart when disconnected from data feed uploaded Feb 21, 2014 by PRIME (PRIME)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates