+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-2088

Portfolio Trader - Data Range not working

action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

Sometimes happens as in the attached picture.
You may have  portfolio of 14 symbols, and when you do the test, you can see the last two (order is not important I think ... I moved symbols around to change their order in the list), and you can see EC and BP won't download all historical data.
Data is taken from Tradestation 9.1, and the other symbols had no issue downloading it. And as I said, this is sometimes reproducible. Other times works like a charm.

Steps to reproduce this issue

Check the attached pic.

Comments (2)
#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Aug 30, 2016 - 12:04

1.It might be due to incorrect cache data in TS or TS disconnections. Reload the chart in TS, then try backtesting in Portfolio Trader once again.
2.The trades do not always take place on the last bars, especially when using daily bars.

#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Aug 30, 2016 - 12:05

If you are able to provide the exact steps of issue reproduction, please send them via email, or come to the Live Chat to demonstrate it.

History
Issue basics
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (2)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
  • Severity
    Normal
Attachments (1)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates