+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-116

Incorrect Study Status Line for not updated every tick, not plotted every bar.

action_vote_minus_faded.png
3
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

When a study is set to not update every tick, and that study does not necessarily
plot on every bar, when the cursor is placed on the current bar, the subchart staus line
shows the last plotted amounts(for each plot) no matter how many bars ago they were actally ploted.
The status line display should actually be blank since it is set to not update every tick.
This appears to happen on various minute bar settings but not on daily, weekly etc.
An example would be a swing chart indicator that highlights the ends of swings in
a subchart, which needs to wait tiill the end of the next bar to determine if a swing has been formed.

Steps to reproduce this issue

Use a 5 minute chart of ZB #F with a swing study not updating every tick
which does not plot every bar.  Put cursor on last(current) bar. 
See info in status line on that specific subchart(not 1) that does not relate to that specific bar.
Try the same with a daily chart and it works differently and correctly.

Comments (4)
#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
Jan 21, 2011 - 07:04

The value in promt and in DataWindow relates the bar which is chosen with cursor. The value in Status Line relates the latest value of plot of the indicator. I have attached video file showing this.
If you mean another problem, please, make a similar video and send/attach it.

#0
user-offline.png  Phil (phil1000)
Feb 11, 2011 - 12:33

When the chart moves to a new bar, does MC initialize the value for each plot?
If not, then the old value would carry over(in the status lline of the subchart) until a new value is calculated.
If you have a noplot, it seems to initialize(remove) the plot on the graph but not remove it from the status line, this is for plot every tick.

#0
user-offline.png  Stan_MultiCharts (Stan_MultiCharts)
May 12, 2011 - 09:36

Could you check the issue and see if it's still reproducible in the latest MultiCharts version? We want to close all of the issues, and we need to see if this one is still applicable. 

#0
user-offline.png  Phil (phil1000)
Jun 07, 2011 - 09:03

The status line display is still displaying old values that do not pertain to the current bar.

History
Issue basics
  • Type of issue
    Bug report
  • Category
    Stability
  • Targeted for
    MultiCharts 7.0 (RELEASED)
  • Status
    Released
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (3)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
  • Severity
    Normal
Attachments (1)
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates