+1 888 340 6572
MultiCharts Project Management
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report MC-941

ASCII Mapping Seems to be Broken

action_vote_minus_faded.png
3
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
Description

With MC 8 Beta 3, ASCII mapping seems to be critically broken.
Charts won't load - they either hang "Waiting for connection" or sometime start to load and just say "Backfilling ..." forever.
The same workspaces (using ASCII mapping) will load and operate fine in MC 7.4, but not in MC 8.0.
Starting with a fresh workspace in a fresh chart is no better.

Steps to reproduce this issue

Just try to load your ASCII mapped data.   Presumably you will see what I see.
I observe that same problem is observed on two separate machines.
It's a complete show-stopper for analysis.

Comments (13)
#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 07, 2012 - 10:03

Would you be able to come to our live chat to demonstrate the issue during remote connection to your computer?

#0
user-offline.png  MC_Prog (MC_Prog)
May 07, 2012 - 13:54

Hi.   Have you not been able to observe/reproduce this yourself?  (IOW, did you try to?   and if so, what did you see?)

#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 09, 2012 - 11:22

Of course, Sir. ASCII mapping worked on our end. That's why i asked you to show the issue during remote connection, because something is different in your environment.

#0
user-offline.png  JoeTrader (Guest)
May 12, 2012 - 03:02

I have the same Problem. Any news on this subject?

#0
user-offline.png  swz168 (swz168)
May 12, 2012 - 06:43

Try to reproduce this issue with this Ascii file: http://www.forextester.com/data/files/EURUSD.zip
It's about 200MB. Ascii Map this with QM, then try to load the whole history into Chart (From Jan 2001 - 30 Apr 2012, Minute Resolution), You'll see, that you won't be able to work with Ascii Mapping. I've once succeeded loading the whole history in Chart with ascii mapping, but the loading took like an eternity (MC7). So it is not workable. As a workaround I import the history into QM.
You should try Online Mode (Download history) and Offline mode. I expect Ascii mapping regardless which mode is selected, but it doesnÄt work. (When once it worked, it worked only in offline mode)

#0
user-offline.png  swz168 (swz168)
May 12, 2012 - 06:46

btw, the speedproblem shouldn't be related with Hardware. I have  i7, 32MB ram and ssd 256GB

#0
user-offline.png  Tresor (Tresor)
May 12, 2012 - 07:52

Andrew, pleas:
1. Load the ascii powered chart - it will appear without problems
2. Then change the resolution - the chart wont' load (with new resolution)

#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 17, 2012 - 07:53

swz168 - do you use any antiviruses?
Could you also attach your workspace?
We will investigate the issue.

#0
user-offline.png  Alex MultiCharts (Alex MultiCharts)
May 17, 2012 - 07:53

swz168 - do you use any antiviruses?
Could you also attach your workspace?
We will investigate the issue.

#0
user-offline.png  JoeTrader (Guest)
May 17, 2012 - 09:50

Andrew, I don't have the right workspace set up, since ASCII Mapping doesn't work. I have created a new Symbol with MBtrading (EURUSD instead of EUR/USD, so no historical data will be added from MBtrading) and then I just import the data from the Ascii file.
It is easy to recreate the situation without workspace: download the file asciii file I provided below. then start quote manager and create a new ascii mapping symbol EURUSD with the ascii file. Then start Multicharts and open a new Chart, choose that new created ascii mapping symbol as instrument and choose the whole intervall (From Jan 2001 - 30 Apr 2012) with 1 min resolution. You will see that the chart won't load.

#0
user-offline.png  JoeTrader (Guest)
May 17, 2012 - 09:54

No Antivrus Software installed. Freshly installed Windows 7 64 Bit, so only Windows Defender active (by Standard).

#0
user-offline.png  swz168 (swz168)
May 29, 2012 - 16:30

A big Thanks to Multicharts Team! Now it works perfekt. Complete history is loaded via Ascii now really really fast! Thanks again!
(For users: remember to delete the old ascii symbols in quote manager and map them new, otherwise it won't work)

#0
user-offline.png  Walterrruiz (Walterrruiz)
Mar 18, 2015 - 04:29

ASCII codes represent text in computers, communications equipment,
and other devices that use text. Most modern character-encoding schemes
are based on ASCII, though they support many additional characters. ASCII developed from telegraphic codes. Its first commercial use was as a 7-bit teleprinter code promoted by Bell data services. The buy essays reviews will help you to find a best writing support.

History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targeted for
    MultiCharts 8.0 (RELEASED)
  • Status
    Released
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (3)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Reproducability
    Not determined
  • Severity
    Critical
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates